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Overview

Handling dialer errors can be done in several ways, depending on the type of error and the desired outcome.


Error 21611

If you received Error 21611, it means that you have attempted to enqueue too many messages for a given "From" number. This error will be thrown when attempting to create additional messages on the same number.

Sample Error 21611

Messages can only be queued for 4 hours - so they automatically fail. If your outbound messages are queueing at a higher rate, your messages will accumulate. After sitting in the queue for 4 hours - those messages will fail and won't be sent.

Possible Cause

Possible Solutions

  • You have attempted to enqueue more than 4 hours' worth of messages from a single number

  • Slow down your sending rate to avoid queuing on your Aloware number

  • If appropriate for your use case, consider using a Messaging Service to better distribute message throughput.


Error 30022

You are receiving Error 30022 because you have reached your carrier's maximum rate for a phone number or campaign.

It happens when you send messages at a higher rate to a particular carrier and has exceeded the maximum limit for the phone number and/or campaign.


Error 30023

Once you reach the maximum carrier's limit for the day of sending messages, you will receive the error 30023.


Error 30027

T-Mobile sets a default daily messaging limit based on your Trust Score. Once you reach the maximum limit, you will receive Error 30027.

T-Mobile limit is applied at Brand Level and is based on the sum of outbound SMS segments and MMS messages on a 24-hour basis and resets every midnight (Pacific US Time).

Trust Score

T-Mobile message limit (SMS segments + MMS) outbound

75 - 100

200,000/ day

50 - 74

40,000/ day

25 - 49

10,000/ day

1 - 24

2,000/ day


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